# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^.*\\/).*/$1/gm;t' <<< "http://xxxx.com/xxx-xxx-xxx-xxxx/ 60% 2 Weekly 2014-01-01 00:00
http://somethingelse.com/123-456-789-0000/ 60% 2 Weekly 2014-01-01 00:00
http://anothersite.com/page/boop/beep/ 60% 2 Weekly 2014-01-01 00:00
http://baloogawhalesarenotaliens.com/ 60% 2 Weekly 2014-01-01 00:00
"