using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^.*\/).*";
string substitution = @"$1";
string input = @"http://xxxx.com/xxx-xxx-xxx-xxxx/ 60% 2 Weekly 2014-01-01 00:00
http://somethingelse.com/123-456-789-0000/ 60% 2 Weekly 2014-01-01 00:00
http://anothersite.com/page/boop/beep/ 60% 2 Weekly 2014-01-01 00:00
http://baloogawhalesarenotaliens.com/ 60% 2 Weekly 2014-01-01 00:00
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}