use strict;
my $str = 'http://xxxx.com/xxx-xxx-xxx-xxxx/ 60% 2 Weekly 2014-01-01 00:00
http://somethingelse.com/123-456-789-0000/ 60% 2 Weekly 2014-01-01 00:00
http://anothersite.com/page/boop/beep/ 60% 2 Weekly 2014-01-01 00:00
http://baloogawhalesarenotaliens.com/ 60% 2 Weekly 2014-01-01 00:00
';
my $regex = qr/(^.*\/).*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";