#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^.*\/).*"
Local $sString = "http://xxxx.com/xxx-xxx-xxx-xxxx/ 60% 2 Weekly 2014-01-01 00:00" & @CRLF & _
"" & @CRLF & _
"http://somethingelse.com/123-456-789-0000/ 60% 2 Weekly 2014-01-01 00:00" & @CRLF & _
"" & @CRLF & _
"http://anothersite.com/page/boop/beep/ 60% 2 Weekly 2014-01-01 00:00" & @CRLF & _
"" & @CRLF & _
"http://baloogawhalesarenotaliens.com/ 60% 2 Weekly 2014-01-01 00:00" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)