// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^.*\/).*").unwrap();
let string = "http://xxxx.com/xxx-xxx-xxx-xxxx/ 60% 2 Weekly 2014-01-01 00:00
http://somethingelse.com/123-456-789-0000/ 60% 2 Weekly 2014-01-01 00:00
http://anothersite.com/page/boop/beep/ 60% 2 Weekly 2014-01-01 00:00
http://baloogawhalesarenotaliens.com/ 60% 2 Weekly 2014-01-01 00:00
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}