# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^.*\/).*"
test_str = ("http://xxxx.com/xxx-xxx-xxx-xxxx/ 60% 2 Weekly 2014-01-01 00:00\n\n"
"http://somethingelse.com/123-456-789-0000/ 60% 2 Weekly 2014-01-01 00:00\n\n"
"http://anothersite.com/page/boop/beep/ 60% 2 Weekly 2014-01-01 00:00\n\n"
"http://baloogawhalesarenotaliens.com/ 60% 2 Weekly 2014-01-01 00:00\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.