# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.?0+$//gm;t' <<< "0.24000
4.1100
200
0.100
1.0
123.450
123.400
123.456
123.000"