import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.?0+$";
final String string = "0.24000\n"
+ "4.1100\n"
+ "200\n"
+ "0.100\n"
+ "1.0\n"
+ "123.450\n"
+ "123.400\n"
+ "123.456\n"
+ "123.000";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}