const regex = /\.?0+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.?0+$', 'gm')
const str = `0.24000
4.1100
200
0.100
1.0
123.450
123.400
123.456
123.000`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);