package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.?0+$`)
var str = `0.24000
4.1100
200
0.100
1.0
123.450
123.400
123.456
123.000`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}