#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\.?0+$"
Local $sString = "0.24000" & @CRLF & _
"4.1100" & @CRLF & _
"200" & @CRLF & _
"0.100" & @CRLF & _
"1.0" & @CRLF & _
"123.450" & @CRLF & _
"123.400" & @CRLF & _
"123.456" & @CRLF & _
"123.000"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)