use strict;
my $str = '0.24000
4.1100
200
0.100
1.0
123.450
123.400
123.456
123.000';
my $regex = qr/\.?0+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";