using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.?0+$";
string substitution = @"";
string input = @"0.24000
4.1100
200
0.100
1.0
123.450
123.400
123.456
123.000";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}