# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\|(?=[^\(\)]*\))/~/g;t' <<< "http://maven/artifactory/libs-snapshot/commons-lang/commons-lang/2.6/commons-lang-2.6.pom (18 KB at 221.9 KB/sec)"