const regex = /\|(?=[^\(\)]*\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|(?=[^\\(\\)]*\\))', 'g')
const str = `http://maven/artifactory/libs-snapshot/commons-lang/commons-lang/2.6/commons-lang-2.6.pom (18 KB at 221.9 KB/sec)`;
const subst = `~`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);