using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\|(?=[^\(\)]*\))";
string substitution = @"~";
string input = @"http://maven/artifactory/libs-snapshot/commons-lang/commons-lang/2.6/commons-lang-2.6.pom (18 KB at 221.9 KB/sec)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}