#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\|(?=[^\(\)]*\))"
Local $sString = "http://maven/artifactory/libs-snapshot/commons-lang/commons-lang/2.6/commons-lang-2.6.pom (18 KB at 221.9 KB/sec)"
Local $sSubst = "~"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)