import Foundation
let pattern = #"\|(?=[^\(\)]*\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://maven/artifactory/libs-snapshot/commons-lang/commons-lang/2.6/commons-lang-2.6.pom (18 KB at 221.9 KB/sec)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"~"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)