import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\|(?=[^\\(\\)]*\\))";
final String string = "http://maven/artifactory/libs-snapshot/commons-lang/commons-lang/2.6/commons-lang-2.6.pom (18 KB at 221.9 KB/sec)";
final String subst = "~";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}