re = /\|(?=[^\(\)]*\))/
str = 'http://maven/artifactory/libs-snapshot/commons-lang/commons-lang/2.6/commons-lang-2.6.pom (18 KB at 221.9 KB/sec)'
subst = '~'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result