use strict;
my $str = 'http://maven/artifactory/libs-snapshot/commons-lang/commons-lang/2.6/commons-lang-2.6.pom (18 KB at 221.9 KB/sec)';
my $regex = qr/\|(?=[^\(\)]*\))/p;
my $subst = '~';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";