package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)\bvirtual\b\s*(.+?)\s*\boverride\s*(.+?)`)
var str = `virtual void test1() const override;
virtual int test2() override { xxx } //an example of commentary
virtual void test3(int p1,
int p2,
int p3) const override;
virtual void test4(int p1,
int p2,
int p3,
int p4) const override;
virtual void testn(int p1,
int p2,
int p3,
int p4,
......,
int pn) const override;
`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}