import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bvirtual\\b\\s*(.+?)\\s*\\boverride\\s*(.+?)";
final String string = "virtual void test1() const override;\n\n"
+ "virtual int test2() override { xxx } //an example of commentary\n\n"
+ "virtual void test3(int p1,\n"
+ " int p2,\n"
+ " int p3) const override;\n"
+ "virtual void test4(int p1,\n"
+ " int p2,\n"
+ " int p3,\n"
+ " int p4) const override;\n\n"
+ "virtual void testn(int p1,\n"
+ " int p2,\n"
+ " int p3,\n"
+ " int p4,\n"
+ " ......,\n"
+ " int pn) const override;\n";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}