re = /\bvirtual\b\s*(.+?)\s*\boverride\s*(.+?)/m
str = 'virtual void test1() const override;
virtual int test2() override { xxx } //an example of commentary
virtual void test3(int p1,
int p2,
int p3) const override;
virtual void test4(int p1,
int p2,
int p3,
int p4) const override;
virtual void testn(int p1,
int p2,
int p3,
int p4,
......,
int pn) const override;
'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result