const regex = /\bvirtual\b\s*(.+?)\s*\boverride\s*(.+?)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bvirtual\\b\\s*(.+?)\\s*\\boverride\\s*(.+?)', 'gms')
const str = `virtual void test1() const override;
virtual int test2() override { xxx } //an example of commentary
virtual void test3(int p1,
int p2,
int p3) const override;
virtual void test4(int p1,
int p2,
int p3,
int p4) const override;
virtual void testn(int p1,
int p2,
int p3,
int p4,
......,
int pn) const override;
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);