// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)\bvirtual\b\s*(.+?)\s*\boverride\s*(.+?)").unwrap();
let string = "virtual void test1() const override;
virtual int test2() override { xxx } //an example of commentary
virtual void test3(int p1,
int p2,
int p3) const override;
virtual void test4(int p1,
int p2,
int p3,
int p4) const override;
virtual void testn(int p1,
int p2,
int p3,
int p4,
......,
int pn) const override;
";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}