import re
regex = re.compile(r"\bvirtual\b\s*(.+?)\s*\boverride\s*(.+?)", flags=re.MULTILINE | re.DOTALL)
test_str = ("virtual void test1() const override;\n\n"
"virtual int test2() override { xxx } //an example of commentary\n\n"
"virtual void test3(int p1,\n"
" int p2,\n"
" int p3) const override;\n"
"virtual void test4(int p1,\n"
" int p2,\n"
" int p3,\n"
" int p4) const override;\n\n"
"virtual void testn(int p1,\n"
" int p2,\n"
" int p3,\n"
" int p4,\n"
" ......,\n"
" int pn) const override;\n")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)