#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "x\([^8\s]*8[^8\s]*\)"
Local $sString = "39x(7,8)" & @CRLF & _
"3x(8)" & @CRLF & _
"2x(8,1)" & @CRLF & _
"3x(8,9)" & @CRLF & _
"1x(11)" & @CRLF & _
"3x(11,7,8)" & @CRLF & _
"11x(11,7,8,9)" & @CRLF & _
"11x(11,7,88,9)" & @CRLF & _
"31x(11,7,8,9,10)" & @CRLF & _
"1x(11,7,8,9,10,12)" & @CRLF & _
"2x(7,8,10)" & @CRLF & _
"224x(7,8,9)" & @CRLF & _
"31x(11,7,8,9,10)" & @CRLF & _
"1x(11,7,9,10,12)" & @CRLF & _
"2x(7,8,10)" & @CRLF & _
"224x(7,8,9)" & @CRLF & _
"13x(7,8,9,10)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")