use strict;
my $str = '39x(7,8)
3x(8)
2x(8,1)
3x(8,9)
1x(11)
3x(11,7,8)
11x(11,7,8,9)
11x(11,7,88,9)
31x(11,7,8,9,10)
1x(11,7,8,9,10,12)
2x(7,8,10)
224x(7,8,9)
31x(11,7,8,9,10)
1x(11,7,9,10,12)
2x(7,8,10)
224x(7,8,9)
13x(7,8,9,10)';
my $regex = qr/x\([^8\s]*8[^8\s]*\)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}