package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`x\([^8\s]*8[^8\s]*\)`)
var str = `39x(7,8)
3x(8)
2x(8,1)
3x(8,9)
1x(11)
3x(11,7,8)
11x(11,7,8,9)
11x(11,7,88,9)
31x(11,7,8,9,10)
1x(11,7,8,9,10,12)
2x(7,8,10)
224x(7,8,9)
31x(11,7,8,9,10)
1x(11,7,9,10,12)
2x(7,8,10)
224x(7,8,9)
13x(7,8,9,10)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}