import re
regex = re.compile(r"x\([^8\s]*8[^8\s]*\)")
test_str = ("39x(7,8)\n"
"3x(8)\n"
"2x(8,1)\n"
"3x(8,9)\n"
"1x(11)\n"
"3x(11,7,8)\n"
"11x(11,7,8,9)\n"
"11x(11,7,88,9)\n"
"31x(11,7,8,9,10)\n"
"1x(11,7,8,9,10,12)\n"
"2x(7,8,10)\n"
"224x(7,8,9)\n"
"31x(11,7,8,9,10)\n"
"1x(11,7,9,10,12)\n"
"2x(7,8,10)\n"
"224x(7,8,9)\n"
"13x(7,8,9,10)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")