import Foundation
let pattern = #"x\([^8\s]*8[^8\s]*\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
39x(7,8)
3x(8)
2x(8,1)
3x(8,9)
1x(11)
3x(11,7,8)
11x(11,7,8,9)
11x(11,7,88,9)
31x(11,7,8,9,10)
1x(11,7,8,9,10,12)
2x(7,8,10)
224x(7,8,9)
31x(11,7,8,9,10)
1x(11,7,9,10,12)
2x(7,8,10)
224x(7,8,9)
13x(7,8,9,10)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)