import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "x\\([^8\\s]*8[^8\\s]*\\)";
final String string = "39x(7,8)\n"
+ "3x(8)\n"
+ "2x(8,1)\n"
+ "3x(8,9)\n"
+ "1x(11)\n"
+ "3x(11,7,8)\n"
+ "11x(11,7,8,9)\n"
+ "11x(11,7,88,9)\n"
+ "31x(11,7,8,9,10)\n"
+ "1x(11,7,8,9,10,12)\n"
+ "2x(7,8,10)\n"
+ "224x(7,8,9)\n"
+ "31x(11,7,8,9,10)\n"
+ "1x(11,7,9,10,12)\n"
+ "2x(7,8,10)\n"
+ "224x(7,8,9)\n"
+ "13x(7,8,9,10)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}