package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+(?:-\w+)?(?: +\/)? +\w+(?:-\w+)?).+`)
var str = `AO SMITH 100108283 4500W/240V SCREW-IN ELEMENT, 11
BRA14X18HEBU / P11-042 / 310-470NL BRASS 1/4 x 1/8 HEX BUSHING
TWO-HOLE PIPE STRAP 4" 008004EG 72E 4`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}