const regex = /^(\w+(?:-\w+)?(?: +\/)? +\w+(?:-\w+)?).+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+(?:-\\w+)?(?: +\\\/)? +\\w+(?:-\\w+)?).+', 'gm')
const str = `AO SMITH 100108283 4500W/240V SCREW-IN ELEMENT, 11
BRA14X18HEBU / P11-042 / 310-470NL BRASS 1/4 x 1/8 HEX BUSHING
TWO-HOLE PIPE STRAP 4" 008004EG 72E 4`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);