#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\d]*?[.][\d]{2}(?=[\s\W])"
Local $sString = "1.00" & @CRLF & _
"1.22" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"1.00000000" & @CRLF & _
"1.ab" & @CRLF & _
"1.(/" & @CRLF & _
"1.(" & @CRLF & _
"1.abs" & @CRLF & _
"3.123" & @CRLF & _
"" & @CRLF & _
"2.13" & @CRLF & _
"12312312123.23" & @CRLF & _
"1,000.23" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")