using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\d]*?[.][\d]{2}(?=[\s\W])";
string input = @"1.00
1.22
1
1.00000000
1.ab
1.(/
1.(
1.abs
3.123
2.13
12312312123.23
1,000.23
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}