import Foundation
let pattern = #"[\d]*?[.][\d]{2}(?=[\s\W])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1.00
1.22
1
1.00000000
1.ab
1.(/
1.(
1.abs
3.123
2.13
12312312123.23
1,000.23
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)