$re = '/[\d]*?[.][\d]{2}(?=[\s\W])/';
$str = '1.00
1.22
1
1.00000000
1.ab
1.(/
1.(
1.abs
3.123
2.13
12312312123.23
1,000.23
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);