const regex = new RegExp('[\\d]*?[.][\\d]{2}(?=[\\s\\W])', 'g')
const str = `1.00
1.22
1
1.00000000
1.ab
1.(/
1.(
1.abs
3.123
2.13
12312312123.23
1,000.23
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}