re = /[\d]*?[.][\d]{2}(?=[\s\W])/
str = '1.00
1.22
1
1.00000000
1.ab
1.(/
1.(
1.abs
3.123
2.13
12312312123.23
1,000.23
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end