import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\d]*?[.][\\d]{2}(?=[\\s\\W])";
final String string = "1.00\n"
+ "1.22\n\n"
+ "1\n"
+ "1.00000000\n"
+ "1.ab\n"
+ "1.(/\n"
+ "1.(\n"
+ "1.abs\n"
+ "3.123\n\n"
+ "2.13\n"
+ "12312312123.23\n"
+ "1,000.23\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}