#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.*[^\n])\n*"
Local $sString = "Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)" & @CRLF & _
"" & @CRLF & _
"Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)" & @CRLF & _
"" & @CRLF & _
"Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)" & @CRLF & _
"" & @CRLF & _
"Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "<li>\1</li>\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)