const regex = /(.*[^\n])\n*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*[^\\n])\\n*', 'g')
const str = `Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
`;
const subst = `<li>\1</li>\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);