using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*[^\n])\n*";
string substitution = @"<li>\1</li>\n";
string input = @"Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}