package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*[^\n])\n*`)
var str = `Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
`
var substitution = "<li>\1</li>\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}