import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*[^\\n])\\n*";
final String string = "Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)\n\n"
+ "Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)\n\n"
+ "Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)\n\n"
+ "Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)\n\n\n\n"
+ "Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)\n\n\n\n"
+ "Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)\n\n\n\n"
+ "Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)\n\n\n";
final String subst = "<li>\\1</li>\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}