import Foundation
let pattern = #"(.*[^\n])\n*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<li>\1</li>\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)