# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*[^\n])\n*"
test_str = ("Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)\n\n"
"Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)\n\n"
"Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)\n\n"
"Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)\n\n\n\n"
"Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)\n\n\n\n"
"Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)\n\n\n\n"
"Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)\n\n\n")
subst = "<li>\\1</li>\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.