use strict;
my $str = 'Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
Awesome test text like lorem’Awesome test text like lorem (Awesome test text like lorem)
';
my $regex = qr/(.*[^\n])\n*/p;
my $subst = '<li>\\1</li>\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";